Tanto en instalaciones nuevas como en upgrades a Prestashop 1.6, es muy probable que si intentáis añadir una página a la categoría CMS, os aparezca un error de «Clave de seguridad no válida», y os pida salir o bien confirmación para continuar (que no os dejará tampoco añadir la página). Tiene solución y no tiene nada que ver con regenerar htaccess

 

Pues bien, como he dicho, para solucionarlo no es necesario ni regenerar htaccess, ni urls, ni nada parecido; ya que lo que sucede es debido a un error de código en uno de los ficheros nativos de Prestashop 1.6

Basta con editar dicho fichero y rectificar el error tal y como explico a continuación.

 

Solución

 

Con un programa como Filezilla o similar, debemos editar el fichero  classes/controller/AdminController.php 

Alrededor de la línea 247 observaremos que aparece el siguiente código:

Captura de pantalla 2014-09-29 a la(s) 18.21.28

El error está en que se han añadido los caracteres amp; de manera incorrecta a continuación del símbolo &. Así que basta con suprimirlos, de manera que la línea de código quede así:

Captura de pantalla 2014-09-29 a la(s) 18.23.30

Guardamos los cambios y asunto solucionado, ya podremos añadir cuantas páginas CMS deseemos sin generar ningún error de clave no válida.

 

Espero que os haya ayudado, y si tenéis alguna duda, aquí estamos 🙂

No votes yet.
Please wait...

Centro de preferencias de privacidad

Necesarias

Se usan para saber si ya aceptaste nuestras políticas, si ya estás suscrito a nuestra newsletter, para reconocer el estado de tu sesión si la tuvieses y para servir más rápidos los contenidos.

No se captura IPs ni siquiera para el servicio de Analytics así que tu visita es privada.

JSESSIONID, _cfuid, wpSGCachePypass, mailerlite, gdpr, gawp

Translate »