Compartir es sexy
  •  
  •  
  •  
  •  

Es posible que tu backoffice deje de funcionar de golpe y además tengas este error en Prestashop FatalErrorException in AdminDashboardController.php line 0. No te compliques en buscar, es un problema de la versión de php. Aquí te lo explico

Puede pasar que, sin que hayas hecho ninguna modificación en tu tienda prestashop, de golpe no puedas acceder a tu backoffice y además tengas ese mensaje de error tan fastidioso.

Y puedes darle mil vueltas pensando si será la cache, si será la última actualización de prestashop, si será que te han hackeado la web, etc

Y nada de lo que pruebes te funcionará, a lo sumo, verás que el mensaje de error cambia, pero sigues sin poder acceder al backoffice.

 

prestashop FatalErrorException in AdminDashboardController.php line 0: Compile Error: Declaration of AdminDashboardControllerCore::setMedia() must be compatible with AdminControllerCore::setMedia($isNewTheme = false)

 

Sí, la verdad es que hace daño a la vista, pero se resuelve de una manera de lo más fácil, rápida y elegante.

Porque lo único que ha cambiado, aunque no lo hayas modificado tú, es la versión de PHP del servidor. Y es motivo suficiente para afectar a la compatibilidad con Symphony.

 

Versiones PHP recomendadas para prestashop 1.7

Desde prestashop se recomienda versiones 7.1 y posteriores. En el momento de la redacción de este post, las anteriores a la 7.1.3.2 ya están obsoletas. Sin embargo, la 7.2, aunque es compatible con prestashop, puede ser incompatible con algunos módulos, y en general se desaconseja. Y la 7.3 o superiores, aún no se han evaluado en este momento para el entorno del que hablamos.

Como ves en este cuadro de compatibilidades, la 7.1 es la más adecuada para las versiones de 1.6 a 1.7 de prestashop

compatibilidad php y prestashop

Compatibilidad php y prestashop

 

Y es que la versión de php es decisiva para el funcionamiento y el buen rendimiento de una web. Una versión no adecuada, puede estar detrás de multitud de errores cuyo origen no parece ser ése. Por ejemplo, aquí tienes otro fallo de funcionamiento de un prestashop provocada por una versión de php incorrecta.

Así pues, a lo que íbamos, para solucionar tu error y poder acceder de nuevo a tu backoffice, sólo tienes que acceder al panel de control de tu servidor, sea Plesk o cPanel. Una vez allí, comprueba qué versión de PHP tiene corriendo, y ajústala a la 7.1

Vuelve a tu tienda, refresca la pantalla, y seguro que ahora ya te va todo como una seda.

Espero que te haya servido, ya me contarás.

Mucha suerte y mucho ecommerce 🙂

Rating: 5.0/5. From 7 votes.
Please wait...

Compartir es sexy
  •  
  •  
  •  
  •