Compartir es sexy
  •  
  •  
  •  
  •  

Si tu prestashop a 1.7 tiene error en debug mode, tienes un problema. Te ayudo a solucionar el ContextErrorException Warning: «continue» targeting switch is equivalent to «break» aquí. Sigue leyendo

Tanto si vienes de actualizar de una versión como si estás en una instalación limpia, puedes encontrarte que, al pasar al debud mode, tu prestashop te muestre una lista de errores del estilo ContextErrorException Warning: «continue» targeting switch is equivalent to «break». Did you mean to use «continue 2» o similares.

Puedes dedicarte a dar vueltas reiniciando módulos, volviendo a subir ficheros o haciendo las mil y una, y no cambiará nada, porque tu error no tiene nada que ver con tu instalación de prestashop. Tu error viene por la versión de php que tienes en el servidor.

Error en debug mode

La solución es muy fácil: comprueba que trabajas con una versión php estable para tu prestashop. Para ello, ve a tu servidor, fíjate en qué versión php tienes, y cámbiala según el siguiente esquema, y comprobarás que, una vez cambiada, el debud mode se ejecuta sin ningún error.

Sigue el gráfico de compatibilidades que te indico a continuación:

Otro problema que también tiene que ver con la versión de php es éste, échale un vistazo por si es tu caso.

Espero que te haya servido.

Mucha suerte y mucho ecommerce 🙂

Rating: 5.0/5. From 2 votes.
Please wait...

Compartir es sexy
  •  
  •  
  •  
  •